1Password, 만료된 인증서로 인해 실행이 안 되는 문제 발생… “새로 업데이트해줘야”

2017.02.21 00:30    작성자: KudoKun

혹시 주말 동안 비밀번호 매니저 앱인 1Password를 사용하다가 “1Password는 1Password 미니에 연결하지 못했습니다”라는 에러 메시지와 함께 1Password를 아예 사용하지 못하는 에러를 접하셨나요? 주말에 만료된 인증서로 인해 1Password에서 아예 실행이 안 되는 문제가 발생했습니다.

애자일비트의 설명에 따르면 1Password의 개발자 인증서가 지난 18일에 만료됐는데, 단순히 새로운 버전으로 업데이트할 때 새로운 인증서를 넣어주면 된다고 생각해서 아무런 조치를 취하지 않았었다고 합니다. 그러나 인증서가 만료되자마자 이미 설치돼 있는 1Password에도 문제를 일으켰습니다. 결국 갱신된 인증서를 탑재한 새로운 1Password(버전 6.5.5)를 배포했다고 밝혔습니다.

다만, 이 업데이트는 수동으로 설치해야 한다는 약간의 번거로움이 존재합니다. 이 링크에서 1Password의 새로운 버전을 내려받아서 설치를 진행한 다음, 이 링크를 클릭해서 1Password를 강제로 종료했다가 재시작하면 됩니다. (브라우저에 따라 앱을 열겠냐는 팝업창이 나올 수도 있습니다) 만약에 같은 에러가 나온다면 종료를 클릭하신 후, 다시 1Password를 실행하면 정상 실행됩니다.

이번 문제는 개발사인 애자일비트(Agilebits)에서 직접 앱을 내려받은 사용자들에게 해당되는 문제로, 맥 앱 스토어에서 내려받은 사용자들에게는 해당되지 않습니다. 애자일비트는 사과를 하면서 “이번 인증서는 2022년까지지만, 그 전에 갱신해서 문제가 없도록 하겠다”고 약속했습니다.

필자: 쿠도군 (KudoKun)

컴퓨터 공학과 출신이지만 글쓰기가 더 편한 변종입니다. 더기어의 인턴 기자로 활동했었으며, KudoCast의 호스트로도 활동하고 있습니다.


참조
1Password for Mac 6.5.5: Manual update required - 애자일비트 블로그

관련 글
인기 비밀번호 관리앱 '1Password' 정액 구독 서비스 출시... SW패키지 판매 방식과 병행
맥용 1Password 6.5 업데이트... 신형 맥북프로의 터치ID∙터치바 지원
[소개] 맥용 개인 정보 관리 프로그램 '1Password' 사용 가이드


저작자 표시 비영리 변경 금지
신고
    
  1. Blog Icon
    Ria-

    안그래도 오늘 안되길래 왜 그런가 해서 재설치 -> 라이센스 재인증 했는데...이런 이유였네요...

  2. Blog Icon
    구달

    저만 그런게 아니었군요..

  3. Blog Icon
    황정호

    아 감사합니다.~~~~~~ 저도 실행이 안되서리....감사

  4. Blog Icon
    마늘대디

    감사합니다.
    링크된 설치파일을 이용하여 처리가 바로 되었습니다 ^^

  5. Blog Icon
    Dr. Ha

    감사합니다.
    갑자기 작동 안되고 라이센스도 찾질 못해서
    걱정했는데 여기서 한번에 해결합니다.

    감사합니다

  6. Blog Icon
    lee

    감사합니다. 잘 해결했습니다.
    앞으로도 좋은 정보 글 부탁드립니다.

  7. Blog Icon
    Jonghak nim

    아, 그렇잖아도 1pass가 실행이 안되서 난감했는데 역시 이곳에 정보가 있네요
    덕분에 잘 해결했습니다. 감사합니다.

  8. Blog Icon
    다음네이트

    저도 문제 해결했습니다.

    그리고 위 글에서 '이 링크' 라는 글자가 더 잘 구분되도록 굵게 처리해 주셨으면 좋겠습니다.
    모르고 지나칠 수 있다고 생각합니다.

  9. Blog Icon
    sangwook lee

    덕분에 잘 해결했습니다. 감사합니다.

  10. Blog Icon
    구독자

    황당했는데 이런 문제였군요. 감사합니다.