현재 사용 중인 맥에 OS X 구버전을 설치할 수 있을까?

2012. 8. 30. 13:04    작성자: ONE™

맥은 PC와 달리 운영체제 설치에 상당한 제한이 있는 편입니다. 

최근 출시된 OS X 마운틴 라이언이 2006~2009년에 출시된 다수의 인텔 맥을 지원하지 않는 것처럼 시스템 최소 사양을 만족하지 못해 운영체제 설치가 불가능한 경우도 있는 반면, 맥이 출시 될 때 기본적으로 설치되는 OS X 보다 그 이전 버전의 OS X도 일반적인 방법으로는 설치가 불가능하며 애플도 설치를 권장하지 않습니다.


➥ 애플 고객 지원 문서 (HT2186) - Mac과 함께 제공된 버전보다 이전 버전의 Mac OS X는 설치하지 마십시오.

예를 들어 2011 맥미니의 경우 작년에 출시될 당시 OS X 라이언이 기본으로 설치되어 있었는데, OS X 라이언 보다 이전 버전, 즉 OS X 스노우 레퍼드는 2011 맥미니에 사실상 설치가 불가능합니다. (각종 트윅과 kext(드라이버) 복제등을 통해 '억지로'  이전 버전의 OS X을 구동하는 방법들이 고안되었지만 맥 사용중 어떤 문제가 발생할지 모르기 때문에 실질적으로 '권장'되는 방법은 아니며 초보자들이 따라하기도 쉽지 않은 편입니다.)

또, 레티나 맥북프로는 현재 OS X 마운틴 라이언이 기본적으로 설치되어 판매되고 있지만, 2012년 6월 출시 당시에는 OS X 라이언이 설치된 채로 판매되었기 때문에 2011 맥미니의 경우와는 달리 양쪽 OS X를 모두 설치할 수 있습니다.

맥을 중고로 구입하신 분들 중 맥에 설치되어 있는 OS X 보다 그 이전 버전의 OS X 설치가 가능한지 여쭤보시는 분들이 많은데 수십종이나 되는 맥에 어떤 OS X을 설치할 수 있는지 개인이 모두 알기란 사실상 불가능하지 않나 싶습니다. 이런 경우 애플이 자체적으로 제공하는 맥 기종 별 출시 시기와 기본 설치 OS X 버전 정보가 있어 추후 참고하시면 좋을 것 같습니다.

➥ 애플 고객 지원 문서 (HT1159) - 컴퓨터별 Mac OS X 버전(빌드)


예를 들어 위 표는 그 동안 선보인 아이맥이 언제 출시 되었고, 또 처음 제품이 출고될 당시 어떤 버전의 OS X이 기본적으로 설치되었는지를 알려주고 있습니다. 

2011 Late iMac의 경우 출시 당시에는 OS X 10.7.3이 설치되어 있었고, 마운틴 라이언이 출시된 현재는 OS X 10.8 버전이 가본으로 설치되는 것을 알 수 있습니다. 위 표를 참조해 2011 Late iMac에 OS X 10.7.2 버전 및 그 이전 버전은 설치가 불가능하며 최소한 OS X 10.7.3 버전이 설치되어야 한다는 것을 알 수 있습니다.

하지만 표 오른쪽의 빌드 정보란에 '11D2011'이라고 되어 있는데 OS X 10.7.3의 일반인 공개 버전의 빌드 넘버가 11D50 였던 것과는 차이가 있습니다. 이는 2011 Late iMac2011 Late iMac에는 해당 기종만을 위한 특별한 버전(빌드)의 OS X 10.7.3이 설치된 채로 출시되었다는 것을 의미합니다. 따라서 10.7.3 버전이라고 해서 아무 설치 디스크를 사용할 수 있는 것은 아니며 2011 아이맥 용으로 나온, 즉 제품 패키지에 동봉되어 있는 OS X 설치 디스크를 사용해야 정상적인 설치가 가능합니다.

Mac OS X 정품이더라도 새 Mac에서 제대로 작동하지 못할 수 있습니다. 정품 버전이 소프트웨어 업데이트를 통해 원래 Mac과 함께 제공된 버전보다 이후 버전의 Mac OS X으로 업데이트되었다 하더라도 예기치 않은 문제가 발생할 수 있습니다. 사용자의 특정 Mac과 함께 배송되는 설치 디스크를 사용하여 운영 체제의 기능을 항상 확인합니다.

위와 같이 애플 고객 지원 페이지에는 원칙적으로 OS X 마스터 버전(일반 판매 버전) 사용도 권장하고 있지 않습니다. (OS X 마스터 버전은 구 OS X이 설치되어 있는 맥을 새로운 메이저 버전으로 업그레이드하기 위한 용도로 판매되어 왔습니다.) 하지만 이 권장 사항은 맥 앱스토어가 도입되기 이전에, 즉 DVD 패키지 판매가 일반적 상황일 때 올라온 것이기 때문에, 항상 최신 버전으로 소프트웨어가 업데이트되는 맥 앱스토어의 특성과는 괴리가 있습니다. 2011 아이맥은 제품 패키지에 기본적으로 동봉되어 있는 설치 디스크를 이용하는 것이 권장되지만, 맥 앱스토어에서 배포되었던 OS X 라이언 마스터 버전을 사용해도 설치나 사용에 아무런 지장이 없습니다.

설명이 다소 장황해 졌는데 현재 사용중인 써드파티 프로그램과의 호환성 문제 등으로 인해 최신 버전의 OS X을 사용하실 수 없는 분들은 위 정보를 참고해 OS X 다운그레이드 작업을 진행하시기 바랍니다.

또한 이번 팁은 인텔 맥 뿐만 아니라 OS 클래식이 설치된 PowerPC 맥 사용자들에게 특히 유용할 것 같습니다.

애플 고객 지원 문서 (HT2191) - Archived - Mac OS: Versions, builds included with PowerPC Macs (since 1998)


참조 자료
애플 고객 지원 문서 (HT2186) - Mac과 함께 제공된 버전보다 이전 버전의 Mac OS X는 설치하지 마십시오.
애플 고객 지원 문서 (HT1159) - 컴퓨터별 Mac OS X 버전(빌드)
애플 고객 지원 문서 (HT2191) - Archived - Mac OS: Versions, builds included with PowerPC Macs (since 1998)

    
  1. 개인적으로 맥북을 두개 쓰고 있는데 한번도 고려해보지 않았던 내용 들이네요 ^^

    좋은글 잘보고 갑니다.