OS X 요세미티 10.10.2 버전을 담은 '콤보 업데이트'에 관하여

2015. 1. 28. 15:54    작성자: ONE™

OS X 요세미티 10.10.2 버전을 설치하기 애플 웹사이트에서 콤보 업데이트 패키지를 받았는데 제대로 작동하지 않는 분 많으시죠? 하드디스크를 선택하는 과정에서 "이 디스크에 설치할 수 없습니다. 이 볼륨은 이 업데이트의 요구사항과 맞지 않습니다.'라는 경고문만 뜨고 말이죠.

이 때문에 업데이트를 담은 인스톨러가 OS X의 버전을 제대로 확인하지 못하는 것이 아닌가 하는 얘기가 보이는데요, 원인은 내부에 포함된 펌웨어 때문인 것으로 알려졌습니다.

콤보 업데이트와 별도로 배포되는 델타 업데이트 안에도 동일한 펌웨어가 포함돼 있는데, 어떤 이유에서인지 콤보 업데이트 안에 있는 펌웨어는 OS X 10.10이 설치된 맥에서만 설치되도록 제한이 걸려 있고, 델타 업데이트 안에 있는 펌웨어는 OS X 10.10.1 이 설치된 맥에서도 설치가 가능하도록 돼 있습니다. 

즉 운영체제를 담은 패키지 자체는 예전처럼 버전을 구분하지 않지만, 펌웨어가 발동을 걸고 있는 것입니다. 왜 이런 제한을 걸어둔 것인지는 애플 개발팀만 알고 있겠죠.

이번 업데이트에 포함된 펌웨어는 썬더볼트를 통해 악성코드가 유입될 수 있는 '썬더스트라이크' 보안 취약점에 대응하기 위해 나온 것으로, 애플은 'CVE-2014-4498'라는 코드로 분류하고 있습니다. 외부에 해킹 방법이 퍼지지 않도록 내용에 관해서는 함구하고 있는데요, 모든 맥이 이 취약점에 영향을 받는 것은 아니며 다음 일부 기종에서만 문제시 된다고 알려졌습니다.

• 맥북프로 레티나 전모델
• 맥북에어 (2013년 중반기 및 이후 모델)
• 아이맥 (2013 하반기 및 이후 모델)
• 맥 프로 (2013년 하반기)

다시 본론으로 돌아와, 이번 업데이트 안에 들어 있는 시스템 펌웨어가 운영체제 버전을 구분하는 관계로 이번 콤보 업데이트는 OS X 사상 처음으로 설치 가능한 맥을 제한하는 유일한 콤보 업데이트가 됐습니다. 따라서 OS X 10.10.2 버전을 설치할 분들은 맥 앱스토어나 델타 업데이트 패키지를 이용하시기 바랍니다. 다음 콤보 업데이트부터는 현재 맥에 설치된 운영체제와는 상관 없이 설치 가능할 것으로 예상됩니다.



참조
Apple Support Forum - 10.10.2 Combo update "can't be installed on this disk"
• Thunderstrike: EFI bootkits for Apple MacBooks
• CNet - 애플 썬더볼트 주의보 “꽂기만 하면 악성코드가…”

관련 글
• 애플, OS X 요세미티 10.10.2 버전에서 '썬더스트라이크' 보안 취약점 수정
• 애플, OS X 요세미티 10.10.2 정식 업데이트 공개


    
  1. Blog Icon
    T

    음.. 그럼 콤보는 포기해야하는 것이군요 제 맥북에는 :,0

    정리해주셔서 감사해요!

  2. Blog Icon
    첨첨

    그럼 앱스토어에서 업데이트할 경우 설치되는 것은 어떤 버전인가요?

  3. 델타 업데이트 입니다.

  4. Blog Icon
    첨첨

    감사합니다. 콤보 다운 중입니다. 설치 후 뵙겠습니다.

  5. Blog Icon
    bwmun

    업데이트를 하긴 했는데 어던건지 모르겠네요...혹시 빌드가...109 이던데 이게 통합 업데이트 인지요..아니면..

  6. 네. 14C109가 정식 버전의 빌드번호 맞습니다.

  7. Blog Icon
    SKY

    그렇군요.. 델타로 다시 받고 있습니다. ^^

  8. Blog Icon
    bwmun

    감사 합니다..정상적으로 업그레이드 된거네요..ㅎㅎㅎㅎ 수고하시고요...

  9. Blog Icon
    흐음

    애초에 나의 구닥다리들은 펌업이 필요 없었단 얘기.. ㅠ.ㅠ